Dengan menggunakan hotspot biasanya ada dua tipe pelanggan, yaitu pelanggan Voucheran dan pelanggan Bulanan yang di bypassed. Nah untuk pelanggan bulanan yang di bypassed kita harus menambahkan IP Binding dan Limit secara manual, dengan menggunakan script ini kita cukup membuat user hotspot untuk pelanggan bulanan dengan sistem bypassed dimana script ini akan membuat simple queue, schedule untuk masa aktif, dan menambahkan MAC Address dan IP Address user hotspot ke IP Binding, setelah masa aktif habis maka akan menghapus IP Binding, menghapus schedule dan menghapus limitnya.

User dengan menggunakan script ini hanya sekali pake, jadi ketika pertama kali login user/voucer akan terhapus, dan device langsung di hapus. Di script pada schedule akan menjalankan empat perintah yaitu, menghapus IP Binding, Menghapus Simple Qeueu, menghapus Cookie dan mengapus schedule.

Sebelum ditambahkan ke user profile, edit dulu max-limit dan parent nya.

adsbygoogle || []).push({});
:local nama "$user";
:local ips [/ip hotspot active get [find user="$nama"] address];
:local server [/ip hotspot active get [find user="$nama"] server];
:local profile [/ip hotspot user get [find name="$nama"] profile];

:local host [/ip dhcp-server lease get [find address="$ips"] host-name];

:local datetime [/system clock get date];

:local timedate [/system clock get time];

:local mac [/ip hotspot active get [find user="$nama"] mac-address];
:local profile [/ip hotspot user get [find name="$nama"] profile];
/system scheduler add interval=30d name="$nama" on-event="/ip hotspot ip-binding remove [find address=$address]; \r\n/queue simple remove [find name=$nama]; \r\n/ip hotspot cookie remove [find user=$nama]; \r\n/sys sche remove [find name=$nama];" start-time=$timedate comment="$datetime $timedate"
:delay 1;
/queue simple add name="$nama" comment=("Login at: [ $timedate ] From: [ $profile ] Hp: [ $host] Server: [$server ]") parent="ALL_TRAFICK" target="$address" max-limit=256K/512K;
:delay 1;
/ip hotspot ip-binding add comment="$nama $datetime $timedate" mac=$mac address=$ips to-address=$ips type=bypassed;
:delay 1;
/ip hotspot user remove [find name="$nama"];
:delay 1;
/ip dhcp-server lease make-static [find address=$ips]

Penambahan script /ip dhcp-server lease make-static [find address=$ips] bertujuan agar Device yang login akan di buat Static di DHCP Server Leases

Artikel yang Direkomendasikan

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Open chat
hii Selamat Datang Di Menara Tower !!!