Script ini dihususkan untuk koneksi Aplikasi Zoom agar tidak tercampur dengan koneksi Umum (Download, Streaming, Browsing), diharapkan ketika client melakukan webinar atau video conference untuk koneksi Zoom tidak terganggu.

Pada halalaman https://support.zoom.us sudah tertera port dan IP Publik / IP Address yang digunakan untuk koneksi Zoom, nah dari informasi ini kita bisa memanfaatkannya untuk membuat mangle dan limit pada Mikrotik.

adsbygoogle || []).push({});

MANGLE UNTUK PRIORITAS APLIKASI ZOOM

/ip firewall mangle
add action=mark-connection chain=prerouting comment=”PORT UMUM” \
dst-address-list=!IP-ZOOM dst-port=\
21,22,23,81,88,5050,843,182,8777,1935,53,8000-8081,80,443 in-interface=\
!ether1-INTERNET new-connection-mark=”PORT UMUM” passthrough=yes \
protocol=tcp
add action=mark-connection chain=prerouting dst-address-list=!IP-ZOOM \
dst-port=21,22,23,81,88,5050,843,182,8777,1935,53,8000-8081,80,443 \
in-interface=!ether1-INTERNET new-connection-mark=”PORT UMUM” \
passthrough=yes protocol=udp
add action=mark-connection chain=prerouting dst-address-list=!IP-ZOOM \
dst-port=67,5228,35915,39397,110,5060,6666,3478,66,53 in-interface=\
!ether1-INTERNET new-connection-mark=”PORT UMUM” passthrough=yes \
protocol=tcp
add action=mark-connection chain=prerouting dst-address-list=!IP-ZOOM \
dst-port=67,5228,35915,39397,110,5060,6666,3478,66,53 in-interface=\
!ether1-INTERNET new-connection-mark=”PORT UMUM” passthrough=yes \
protocol=tcp
add action=mark-packet chain=forward connection-mark=”PORT UMUM” \
in-interface=ether1-INTERNET new-packet-mark=PORT-UMUM-DOWNLOAD \
passthrough=yes
add action=mark-packet chain=forward connection-mark=”PORT UMUM” \
new-packet-mark=PORT-UMUM-UPLOAD out-interface=ether1-INTERNET \
passthrough=yes
add action=mark-connection chain=prerouting comment=ZOOM dst-port=\
5091,8801,8802 in-interface=!ether1-INTERNET new-connection-mark=\
ZOOM-CONN passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting dst-port=\
3478,3479,5090,5091,8801-8810,20000-64000 in-interface=!ether1-INTERNET \
new-connection-mark=ZOOM-CONN passthrough=yes protocol=udp
add action=mark-connection chain=prerouting dst-address-list=IP-ZOOM \
dst-port=80,443 in-interface=!ether1-INTERNET new-connection-mark=\
ZOOM-CONN passthrough=yes protocol=tcp
add action=mark-packet chain=forward connection-mark=ZOOM-CONN in-interface=\
ether1-INTERNET new-packet-mark=ZOOM-PACKET-DOWN passthrough=yes
add action=mark-packet chain=forward connection-mark=ZOOM-CONN \
new-packet-mark=ZOOM-PACKET-UP out-interface=ether1-INTERNET passthrough=\
yes
add action=mark-connection chain=prerouting comment=”PORT RANDOM” \
connection-mark=”!PORT UMUM” dst-address-list=!IP-ZOOM in-interface=\
!ether1-INTERNET new-connection-mark=”PORT RANDOM” passthrough=yes \
protocol=tcp
add action=mark-connection chain=prerouting connection-mark=”!PORT UMUM” \
dst-address-list=!IP-ZOOM in-interface=!ether1-INTERNET \
new-connection-mark=”PORT RANDOM” passthrough=yes protocol=udp
add action=mark-packet chain=forward connection-mark=”PORT RANDOM” \
in-interface=ether1-INTERNET new-packet-mark=PORT-RANDOM-DOWN \
packet-mark=!ZOOM-PACKET-DOWN passthrough=yes
add action=mark-packet chain=forward connection-mark=”PORT RANDOM” \
new-packet-mark=PORT-RANDOM-UP out-interface=ether1-INTERNET packet-mark=\
!ZOOM-PACKET-UP passthrough=yes
add action=add-dst-to-address-list address-list=”IP BUKAN UMUM BERAT” \
address-list-timeout=1m chain=prerouting comment=”PORT RANDOM BERAT” \
connection-mark=”!PORT UMUM” connection-rate=1M-100M dst-address-list=\
!IP-ZOOM in-interface=!ether1-INTERNET protocol=tcp
add action=add-dst-to-address-list address-list=”IP BUKAN UMUM BERAT” \
address-list-timeout=1m chain=prerouting connection-mark=”!PORT UMUM” \
connection-rate=1M-100M dst-address-list=!IP-ZOOM in-interface=\
!ether1-INTERNET protocol=udp
add action=mark-packet chain=forward dst-address-list=”IP BUKAN UMUM BERAT” \
in-interface=ether1-INTERNET new-packet-mark=PORT-RANDOM-BERAT-DOWN \
passthrough=yes
add action=mark-packet chain=forward dst-address-list=”IP BUKAN UMUM BERAT” \
new-packet-mark=PORT-RANDOM-BERAT-UP out-interface=ether1-INTERNET \
passthrough=yes
add action=add-dst-to-address-list address-list=IP-ZOOM address-list-timeout=\
none-dynamic chain=prerouting comment=ZOOM dst-address-list=!IP-ZOOM \
dst-port=5091,8801,8802 in-interface=!ether1-INTERNET protocol=tcp
add action=add-dst-to-address-list address-list=IP-ZOOM address-list-timeout=\
none-dynamic chain=prerouting dst-address-list=!IP-ZOOM dst-port=\
3478,3479,5090,5091,8801-8810,20000-64000 in-interface=!ether1-INTERNET \
protocol=udp
add action=mark-packet chain=forward comment=”CLIENT DOWNLOAD” \
connection-mark=”PORT UMUM” dst-address-list=IP_LOCAL in-interface=\
ether1-INTERNET new-packet-mark=”CLIENT DOWNLOAD” passthrough=yes
add action=mark-packet chain=forward comment=”CLIENT UPLOAD” connection-mark=\
“PORT UMUM” new-packet-mark=”CLIENT UPLOAD” out-interface=ether1-INTERNET \
passthrough=yes src-address-list=IP_LOCAL
/queue simple
add max-limit=5M/5M name=ZOOM packet-marks=ZOOM-PACKET-DOWN,ZOOM-PACKET-UP \
priority=1/1 target=192.168.100.0/24
add name=”ALL CLIENT” packet-marks=”PORT-RANDOM-DOWN,PORT-RANDOM-UP,PORT-RANDO\
M-BERAT-DOWN,PortUmum_Down,PortUmum_UP,PORT-RANDOM-BERAT-UP,CLIENT UPLOAD,\
CLIENT DOWNLOAD” target=192.168.100.0/24
add max-limit=128k/128k name=SERVER parent=”ALL CLIENT” target=\
192.168.100.254/24
/queue tree
add max-limit=50M name=”DOWNLOAD ALL DARI ISP” parent=global queue=\
pcq-download-default
add max-limit=5M name=”UPLUAD ALL DARI ISP” parent=global queue=\
pcq-upload-default
add max-limit=45M name=”1.TOTAL DOWNLOAD ALL CLIEN” parent=\
“DOWNLOAD ALL DARI ISP” queue=pcq-download-default
add name=”2. ZOOM DOWN” packet-mark=ZOOM-PACKET-DOWN parent=\
“DOWNLOAD ALL DARI ISP” priority=1 queue=pcq-download-default
add name=”PORT RANDOM BERAT DOWN” packet-mark=PORT-RANDOM-BERAT-DOWN parent=\
“1.TOTAL DOWNLOAD ALL CLIEN” queue=pcq-download-default
add name=”PORT RANDOM DOWN” packet-mark=PORT-RANDOM-DOWN parent=\
“1.TOTAL DOWNLOAD ALL CLIEN” queue=pcq-download-default
add max-limit=3M name=”1.TOTAL UPLOAD ALL CLIEN” parent=”UPLUAD ALL DARI ISP” \
queue=pcq-upload-default
add name=”PORT RANDOM BERAT UPLUAD” packet-mark=PORT-RANDOM-BERAT-UP parent=\
“1.TOTAL UPLOAD ALL CLIEN” queue=pcq-upload-default
add name=”PORT RANDOM UPLOAD” packet-mark=PORT-RANDOM-UP parent=\
“1.TOTAL UPLOAD ALL CLIEN” queue=pcq-upload-default
add name=”ZOOM UPLUAD” packet-mark=ZOOM-PACKET-UP parent=\
“UPLUAD ALL DARI ISP” priority=1 queue=pcq-upload-default
add max-limit=1M name=”CLIENT DOWNLOAD” packet-mark=”CLIENT DOWNLOAD” parent=\
“1.TOTAL DOWNLOAD ALL CLIEN” queue=pcq-download-default
add max-limit=1M name=”CLIENT UPLOAD” packet-mark=”CLIENT UPLOAD” parent=\
“1.TOTAL UPLOAD ALL CLIEN” queue=pcq-upload-default

Artikel yang Direkomendasikan

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Open chat
hii Selamat Datang Di Menara Tower !!!