Tunneling adalah teknik menghubungkan Jaringan local dengan jaringan public (internet) agar bisa saling terhubung / berkomunikasi melalui sebuah “terowongan” atau tunnel.

Dalam teknik Tunneling ini, nantinya paket data yang dikirim akan dilakukan proses encapsulation (enkapsulasi). Paket data ini nantinya akan dibungkus, dan akan menghasilkan paket data baru oleh protocol lain. Setelah itu, Paket data yang baru tersebut akan dikirim melalui tunnel tadi.

Pada tutorial kali ini saya akan membahas cara membuat server PPPOE untuk pelanggan bulanan, jadi dengan sistem yang akan saya buat ini ketika pelanggan PPPOE bulanan terkoneksi pertama kali ke server PPPOE akan dibuatkan sebuah scheduler baru dengan interval 30d atau 30 hari dengan menjalankan sebuah script untuk memutus koneksi PPPOE pelanggan yang akfif, dan mengganti nama profile untuk pelanggan tersebut degan nama profile expire, yang nantinya akan berfungsi sebagai notifikasi/pemberitahuan atau akan menampilkan halaman isolir. Untuk membuat halaman isolir akan dibahas pada tutorial berikutnya.

PPPoE SERVER (POINT TO POINT PROTOCOL OVER ETHERNET)

PPPoE atau Point to Point Protocol over Ethernet adalah pengembangan dari PPP (Point to Point Protocol). PPP sendiri adalah Protocol Point to Point yang digunakan untuk menghubungkan langsung antara perangkat satu dengan perangkat lain nya. PPP diterapkan pada serial Modem, agar modem tersebut terhubung langsung atau face-to-face dengan ISP.

Buat IP Pool

Buat IP Pool yang digunakan husus untuk client PPPoE dimana IP Pool yang dibuat ada dua, yaitu:

  • IP Pool PPPOE: 192.168.2.3-192.168.2.254
  • IP Pool Expire: 10.10.10.2-10.10.10.254

Tambahkan IP Address

Aktifkan Server PPPoE

Untuk membuat server PPPoE aktifkan dulu PPPTP server dengan cara ke menu PPP –> PPTP Server,seperti pada gambar dibawah ini

Buat PPP Profile

Saya membuat dua PPP Profile seperti pada gambar dibawah ini, dan atur limit sesuai yang diinginkan.

Tambahkan script, scipt ini akan membuat sebuah scheduler baru dengan interval 30d, jadi setelah 30 hari user PPPoE akan di diskonek, dan mengganti profile tersebut ke profile Expire

adsbygoogle || []).push({});
{
:local usernya $user;
:if ([/system schedule find name=$usernya]="") do={
/system schedule add name=$usernya interval=30d on-event="/ppp secret set profile=Expire [find name=$usernya]\r\n/ppp active remove [find name=$usernya]\r\n/system schedule remove [find name=$usernya]"
}
}

Profile untuk Expire

Buat PPPoE Server
Selanjutnya buat PPPoE Server dan masukkan nama interface yang akan digunakan untuk PPPoE

Scheduler Masa aktif Bulanan
Ketika pelanggan bulanan pertama kali terhubung ke server PPPoE maka akan membuat sebuah scheduler sesuai dengan nama di ppp secret
Scheduler ini akan mengganti profile ke Expire, menghapus pelanggan PPPoE yang aktif dan menghapus Scheduler tersebut
Menghubungkan ke Komputer
Untuk menghubungkan PPPoE Server Mikrotik ke Komputer caranya tambahkan sebuah koneksi Broadband (PPPoE), kemudian masukkan username dan password PPPoE


Blokir Pelanggan Expire
Untuk Memblikir pelanggan Expire tambahkan dulu Address List untuk pelanggan Expire, sesuai dengan IP Pool yang telah dibuat tadi

Drop koneksi address list expire
/ip firewall filterr add chain=forward action=drop src-address-list= Expire

Artikel yang Direkomendasikan

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Open chat
hii Selamat Datang Di Menara Tower !!!