Pada tutorial kali ini akan membahas langkah langkah untuk mengalihkan trafik sosial media ke VPN, Tujuannya sama seperti kita me routingkan trafik game ke VPN, agar koneksi menjadi lancar. Jadi trafik sosial media akan mengarah ke VPN dan trafik biasa selain sosial media tetap mengarah ke ISP

Pad kasus ini saya menggunakan VPN Yang mau tau harganya bisa lihat di web ini https://www.menaratower.my.id/ dan saya hubungkan ke mikrotik dengan protocol PPTP. Saya sudah tes menggunakan server Indonesia dan Singapura dan lancar.

Sebelumnya kita harus membuat mangle untuk koneksi sosmed terlebih dahulu

1. Tambahkan raw sosial media, Fungsi raw yaitu menangkap addres list/alamat IP dari beberapa sosmed disini saya menambahkan Instagram, WA, Facebook, Twitter, Telegram, dan Tiktok (jika ingin menambahkan silahkan anda tambahkan sendiri)

Src Addres List: lokal

Dst Address List: !kecuali

Action: Add dst to address list : sosmed

Agar memudahkan gunakan script dibawah ini (sesuaikan dengan settingan di Mikrotik anda)

/ip firewall raw
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=INSTAGRAM content=.cdninstagram.com \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=INSTAGRAM content=\
 scontent-sin6-2.cdninstagram.com dst-address-list=!kecuali \
 src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=INSTAGRAM content=.instagram.com \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=WHATSAPP content=.whatsapp.net \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=WHATSAPP content=.whatsapp.com \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=fb content=.facebook.com dst-address-list=\
 !kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=fb content=.facebook.net dst-address-list=\
 !kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=fb content=.fbcdn.net dst-address-list=\
 !kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=twitter content=.twitter.com \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=twitter content=twitter.com dst-address-list=\
 !kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=twitter content=.twimg.com dst-address-list=\
 !kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=.telegram.org content=.telegram.org disabled=\
 yes dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=.telegram.org content=telegram.org \
 dst-address-list=!kecuali src-address-list=lokal
add action=add-dst-to-address-list address-list=sosmed address-list-timeout=\
 1d chain=prerouting comment=tiktokcdn.com content=tiktokcdn.com \
 dst-address-list=!kecuali src-address-list=lokal

Hasil akhirnya akan terlihat seperti dibawah ini:

2. Tambahkan Layer7 untuk sosmed

adsbygoogle || []).push({});
/ip firewall layer7-protocol
add name=L7-SOSMED regexp="^.+(fbcdn.net|twimg.com|twitter.com|tiktokcdn.com|l\
 ine-scdn.net|facebook.com|instagram.com).*\$"

UPDATE OKTOBER 2020: Tidak prlu menambah L7, Silahkan hapus L7 di mark packet dan Layer7 nya, cukup dengan raw

3. Setelah itu buat mangle

Mangle ini berfungsi menandai koneksi yang sudah ditangkap oleh raw tadi, disini juga akan dibuat mark routing untuk membelokkan trafik sosmed nya ke VPN

/ip firewall mangle
add action=mark-connection chain=postrouting comment=SOSMED dst-address-list=\
 sosmed layer7-protocol=L7-SOSMED new-connection-mark=SOSMED passthrough=\
 yes src-address-list=lokal
add action=mark-packet chain=forward in-interface=PUREVPN\
 new-packet-mark="SOSMED DOWN ISP1" passthrough=yes src-address-list=\
 sosmed
add action=mark-packet chain=forward dst-address-list=sosmed new-packet-mark=\
 "SOSMED UP ISP1" out-interface=PUREVPN passthrough=yes
add action=mark-routing chain=prerouting disabled=yes dst-address-list=sosmed \
 new-routing-mark="TRAFIK SOSMED" passthrough=yes src-address-list=lokal

Interface disini saya arahkan ke PUREVPN yang merupakan interface dari VPN itu sendiri, sesuaikan dengan settingan di router anda.

4. Setelah Mangle terbentuk maka kita buat routing nya untuk mengarahkan ke gateway VPN

/ip route
add distance=1 gateway=PUREVPN routing-mark="TRAFIK SOSMED"

Kolom Routing Mark diisi TRAFIK SOSMED sesuai nama yang kita buat saat membuat mangle tadi

Sampai tahap ini trafik sosmed sudah mengarah ke gateway VPN.

5. Selanjutnya kita membuat queue agar koneksinya tidak melebihi limit yang ada dan tidak mengganggu trafik lain.

/queue tree
add name="f.isp1-sosmed down" packet-mark="SOSMED DOWN ISP1" parent=\
 "4.ISP1-ALL TRAFIC DOWN" queue=pcq-download-default
add name="f.isp-1-sosmed Up" packet-mark="SOSMED UP ISP1" parent=\
 "4.ISP1-ALL TRAFIC UP" queue=pcq-upload-default

Selain melihat trafik di Queue Tree silahkan lihat trafik di interface VPN anda.

Sampai tahap ini maka langkah langkah sudah selesai.

Artikel yang Direkomendasikan

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Open chat
hii Selamat Datang Di Menara Tower !!!